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Sparkrock's Customer Success Center

Updating Licenses

Information

  • Products: Sparkrock for NAV 2016
  • Summary: A new license needs to be applied

Details

Symptoms 
  • A new license for Sparkrock for NAV 2016 needs to be applied.

Cause

A license change might be required to add functionality, or change the number of licensed users in your Sparkrock solution.

Impact / Risks

Changing your license might remove/add features. The new license should be first applied to the QA (UAT) environment. Once it has been verified it works as expected, it can be applied to the Production environment,

Resolution

To resolve this issue follow these steps:

 

1. Locate and open the Dynamics NAV Development Environment.
2. Go to Tools / License Information
3. A window will open which will include the details of currently uploaded license file. 
4. To upload the license, click on the "Upload" button. A window opens allowing you to select your file. 

Once you select the license file it will upload your license to your database. 
License 1.png

Note: upload should be only sufficient if there is no default license in the database.

To ensure the license you just uploaded is the default for your database, please follow the following instructions.

 

Upload a license file for a specific database

  1. In the development environment, on the File menu, point to Database, and then choose Alter.

  2. In the Alter Database window, choose Integration, and then select Save license in database

license 2.png

 3. Restart all Microsoft Dynamics NAV server instances on the computer to activate the license for other clients. 

 

Workaround

n/a    

Related Information

For license changes, please create a support case or contact us at support@sparkrock.com

 

Update History

Add dates and actions pertinent to the history of the issue, including any links. (see sample below)

Date Details Link
01/18/2019 First version of this document was created.  
     
     

Keywords/tags

license, change, NAV

Attachment

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